heartbleed

Earlier this week a serious security vulnerability was announced in the OpenSSL project (http://heartbleed.com/). This issue has the ability to affect a large portion of the internet.

In response to this new vulnerability, the ScreenScape team has completed an internal review of all servers involved with the client-facing operations of our product.

We’ve determined that the versions of OpenSSL used in the ScreenScape infrastructure are free of this issue.

ScreenScape members are not required to change their passwords in response to this issue.

If you have any questions on this or any other security related issues please contact us at ScreenScape Support.